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Overview 
The iwrite word processor is one of several plug-in components available for the iwrite.4.life system.  

It does not work as a stand-alone program.  

This document does not tell you how to operate iwrite.4.life. It explains only the features of the word 

processor plug-in. See the iwrite.4.life help for an introduction to the iwrite.4.life framework. 

The functionality of the iwrite word processor is similar to what you may know from programs like 

Microsoft® Word. The major difference is iwrite’s integration with iwrite.4.life, which supplies the 

entire infrastructure, like full-text searching across all items (not just a single document), 

organization of items into topics and info types, navigation, and more. 

If you believe that you need only a more limited functionality, take a look at the itext™ text editor 

plug-in that comes with iwrite.4.life. This may be all you need for simple journal writing – and you get 

it at no additional cost. At http://www.rightmindlogic.com/products/plugins.html you’ll find 

information about all available and upcoming plug-in modules, e.g., for nutrition and exercise 

monitoring. You can also find a description of the capabilities of and the philosophy behind the 

iwrite.4.life system at our website. 

(Ï× ÔÏ ÉÎÓÔÁÌÌ ÔÈÅ É×ÒÉÔÅΆ word processor 
1. You can download iwrite here: 

http://www.rightmindlogic.com/products/plugins/iwrite_setup/iwrite_component.zip. 

2. Extract the files in the zip archive to your disk (right-click the archive and select Extract All). 

3. Double-click the extracted setup.exe file and follow the instructions. 

4. Once iwrite is installed, it will run as a trial version for 30 days. You can either wait until you 

are asked to enter a license key or, if you already bought iwrite, you can now immediately 

enter the license key you were emailed:  

a. Start iwrite.4.life if it’s not running. 

b. Create a new journal item by pressing Ctrl+N. 

c. On the dialog that appears, select iwrite.4.life word processor plugin from the 

ItemType list and click OK. 

d. Now that you have an empty iwrite journal item, select 9ƴǘŜǊ [ƛŎŜƴǎŜ YŜȅΧ from the 

Help menu of iwrite and copy and paste the license key we emailed you (Make sure 

you store the email with the attached license file in a safe place). To copy and paste 

the key open the license file attached to the email with a text editor (like Windows 

Notepad), press Ctrl+A to mark the contents of the file, then press Ctrl+C to copy the 

contents; now click the empty license field on the Enter License Key… dialog and 

press Ctrl+V to insert the license. Then click OK. 

Use this iwrite Help menu: 

 

Note that iwrite, like all plug-ins, must be installed after the iwrite.4.life system. 

http://www.rightmindlogic.com/products/plugins.html
http://www.rightmindlogic.com/products/plugins/iwrite_setup/iwrite_component.zip
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How the É×ÒÉÔÅΆ word processor plugs into iwrite.4.lifeΆ 
This is the iwrite.4.life framework without any plug-in: 

 

Once you have installed the iwrite word processor you can use it to create, edit, and display journal 

items.  

If you want to create a new iwrite journal item, press Ctrl+N and select the iwrite plugin from the list 

of item types:  

 

If you open a journal item that was created with iwrite, the iwrite.4.life system will automatically 

load the correct plugin and open the item with it. 

This is what iwrite looks like when plugged into the iwrite.4.life system, with an iwrite journal item 

loaded into it: 

Plug-in modules appear in this Work Area 
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How items are organized in iwrite.4.life 
Items you create with the word processor are stored within iwrite.4.life and, like all items, are 

organized by date, time of day, topic, and information type (called InfoType in iwrite.4.life) as you 

can see in the following image: 

 

1: The item’s date – A day 

can contain any number 

of topics. 

2: The item’s Topic – A Topic 

can contain any number of 

InfoTypes. 
4: The item’s 

time of day 

3: The item’s InfoType  – An InfoType 

can contain any number of time 

stamped items. 
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É×ÒÉÔÅΆ ÓÁÍÐÌÅ ÄÏÃÕÍÅÎÔ 
To get an idea what is possible with iwrite in terms of document layout take a look at this page, 

which is the first page of a two-page sample document: 

 

Some of the highlights of this page are: 

¶ Headers and footers with images 

¶ Landscape format (The second page continues a complex layout in portrait format) 

¶ Nested formatted tables 

¶ Multi-column layout 

¶ Structured numbered lists 

¶ Text frames that can be freely positioned on the page 

http://www.rightmindlogic.com/resources/test_data/iwr_demo.docx
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É×ÒÉÔÅΆ 2ÅÆÅÒÅÎÃÅ 

Menus 

 

Don’t confuse these menus with the menus of iwrite.4.life, which is the host for plugins like the 

iwrite word processor. The iwrite.4.life menus and toolbars appear at the very top of the program 

window whereas the iwrite menus appear at the top of the Work Area. 

File Menu 

 

3ÁÖÅ )ÔÅÍ !Óȣ 

The iwrite.4.life system saves items automatically when you exit the program or when you close a 

day tab. In addition, you can turn on the time-based Auto-Save function in iwrite.4.life if you like. 

Therefore, you will need the {ŀǾŜ LǘŜƳ !ǎΧ function only if you want to export an item in order to 

edit it in some other program or if you want to send it to someone. 

If you do select {ŀǾŜ LǘŜƳ !ǎΧ, a standard Windows Save AsΧ dialog will be displayed where you can 

select the location where you want to save the item as a file. You have a choice of formats as you can 

see from the following screen shot: 

 

0ÁÇÅ 3ÅÔÕÐȣ 

The tŀƎŜ {ŜǘǳǇΧ menu item displays a dialog where you can modify the page layout of your word 

processor item: 



iwrite™ word processor manual 
 

© 2011 Right Mind Logic, Wolfgang Braun. All rights reserved.  8 

 

0ÒÉÎÔȣ 

The tǊƛƴǘΧ menu item displays a standard print dialog: 
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0ÒÉÎÔ 0ÒÅÖÉÅ×ȣ 

The tǊƛƴǘ tǊŜǾƛŜǿΧ menu item displays the word processor item as it will appear when printed. You 

can also print the item from the tǊƛƴǘ tǊŜǾƛŜǿΧ dialog. 

 

Edit Menu 
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The menu items on the Edit menu are self-explanatory: They behave as in most word processors. 

Note that hyperlinks and bookmarks in your journal item can only be selected for editing if a 

hyperlink or target has already been inserted (see Insert menu). 

View Menu 

 

The iwrite.4.life word processor offers two different ways of viewing the text: In Page View all your 

formatting will be applied to the text and the page layout will closely resemble the printed version, 

whereas in Draft view you will only see a rough draft of the final version. Draft view was originally 

introduced in word processors when computers were much slower and it might have taken too long 

to always render all formatting. With modern computers you will rarely need Draft view for 

performance reasons. 

You can also decide whether you want to see the toolbar, status bar, and the horizontal and vertical 

ruler. 

You can change the zoom factor (between 25% and 300%). 

Finally, you can open the built-in English-language thesaurus to search for word meanings and 

synonyms: 
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Insert Menu 

 

You can insert files, images, text frames for advanced page layout, hyperlinks to local or web 

addresses, bookmarks (Target…) within the active journal item, page breaks, and headers and 

footers. 

 

Format Menu 

 

#ÈÁÒÁÃÔÅÒȣ 

Use the Character dialog to change character attributes of the selected text: 
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Paragrap Èȣ 

Use the Paragraph dialog to change attributes of the selected paragraphs: 
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4ÁÂÓȣ 

Use the Tabs dialog to set, clear, or modify tabs: 
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Bullets And Numberingȣ 

If you click .ǳƭƭŜǘǎ !ƴŘ bǳƳōŜǊƛƴƎΧ a sub-menu will appear where you can make further choices for 

the numbering style. You can also use the sub-menu to increase or decrease the hierarchical level of 

a list item, i.e., not only will the list item’s indentation be changed but also its logical numbering and 

those of its predecessors and successors. The same effect can be achieved by pressing Tab or 

Shift+Tab. 

 

If you select !ǘǘǊƛōǳǘŜǎΧ on the .ǳƭƭŜǘǎ !ƴŘ bǳƳōŜǊƛƴƎΧ sub-menu the dialog Bullets and Numbering 

will open. As you can see below, you can modify many attributes of bullet lists and numbered lists to 

adapt them completely to your needs. 



iwrite™ word processor manual 
 

© 2011 Right Mind Logic, Wolfgang Braun. All rights reserved.  15 

 

3ÔÙÌÅÓȣ 

 

On this dialog you can create, delete, and modify new styles that will be stored for the active journal 

item. Your styles will appear on the Paragraph Styles drop-down list on the toolbar. 
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(ÅÁÄÅÒÓ !ÎÄ &ÏÏÔÅÒÓȣ 

 

Set the headers’ and footers’ distance from the page border on this dialog. 

Note: this menu item is only enabled if the active item contains headers and footers. 

)ÍÁÇÅȣ 

The Image Attributes dialog has three tabs that let you control layout and position, size and 

distance, and saving options:  

Note: this menu item is only enabled if an image is selected in the active item (Use the Insert menu 

to insert images). 
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4ÅØÔ &ÒÁÍÅȣ 

Text frames, like images, can be freely positioned on the page and in relation to other elements on 

the page. 

The Text Frame Attributes dialog has three tabs that let you control layout and position, size and 

distance, and frame and color:  

Note: this menu item is only enabled if a text frame is selected in the active item (Use the Insert 

menu to insert text frames). 
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Text Frame Marker Lines  

You can set the frame on a text frame (its border line) to zero width. If you do that and still want to 

be able to see the exact border line of the text frame, check this menu item. It will display a thin 

border around a frame-less text frame for visual reference. 

4ÅØÔ #ÏÌÏÒȣ 

If you select this menu item a standard color picker dialog will let you choose a color for the selected 

text. 

4ÅØÔ "ÁÃËÇÒÏÕÎÄ #ÏÌÏÒȣ 

If you select this menu item a standard color picker dialog will let you choose a background color for 

the selected text (this is like highlighting the text). 

$ÏÃÕÍÅÎÔ "ÁÃËÇÒÏÕÎÄ #ÏÌÏÒȣ 

If you select this menu item a standard color picker dialog will let you choose a color for the page 

background of the active item (a “paper” color). 

Table Menu 

 

Click the Insert menu item and select Table from the sub-menu to display the Insert Table dialog 

where you can choose the number of rows and columns for the table to be inserted. 

 

To insert further rows and columns into a table select the appropriate menu item from the Insert 

sub-menu of the Table menu. 

To delete rows or columns from a selected table or the entire table, use the Delete sub-menu. 

To split a table horizontally, use the Split sub-menu. You can choose whether to split the table above 

or below the selected row. 



iwrite™ word processor manual 
 

© 2011 Right Mind Logic, Wolfgang Braun. All rights reserved.  21 

To select an entire table, or an individual row or cell, use the Select sub-menu. 

If a table has no content and no border lines it will not be visible. Select Grid Lines from the Table 

menu to display a light grey border line around the table cells. Note that this is only a visual 

reference. The table doesn’t really have those border lines. If you want the table to have border lines 

(that will print for example) click tǊƻǇŜǊǘƛŜǎΧ on the Table menu and choose frame settings on the 

Table Properties dialog: 

 

You can also set a table background color and cell margins on the Frame and Color tab of the Table 

Properties dialog. 

There are some further layout options on the Size and Formatting tab: 
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Help Menu 

 

The HelpΧ menu item opens this help file. Note that Adobe Reader or some other program capable 

to view pdf files is required. 

The {ǳǇǇƻǊǘΧ, DƛǾŜ ¦ǎ CŜŜŘōŀŎƪΧ, and .ǳȅΧ menu items will open your web browser and take you 

to the respective pages on our website. 

The 9ƴǘŜǊ [ƛŎŜƴǎŜ YŜȅΧ menu item will display the following dialog. Copy & paste the license key we 

emailed you in the text box and press OK. Your license key will then be permanently stored. 
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Toolbar 

 

Don’t confuse this toolbar with the toolbars of iwrite.4.life, which is the host for plugins like the 

iwrite word processor. The iwrite.4.life menus and toolbars appear at the very top of the program 

window whereas the iwrite toolbar appears at the top of the Work Area. 

Drop-down lists 

Paragraph Styles 

 

You can use the Paragraph Styles drop-down box to reset the selected paragraph’s style to the 

default style (e.g., font will be Arial and font size will be 12) by selecting [Normal] from the drop-

down box. Unless you define your own styles per journal item [Normal] will be the only style on the 

list. If you do define your own styles they will be stored for the active journal item and will appear on 

the drop-down list from then on. 

Fonts 

 

The Fonts drop-down box will display the fonts installed on your system. The selected font will be 

applied to the selected text. 

Font Size 

 

The selected font size will be applied to the selected text. 
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Zoom 

 

You can select a zoom factor between 10% and 400% from this drop-down box. 

Buttons 

Increase Font Size 

Clicking this button increases the font size of the selected text. 

Decrease Font Size 

Clicking this button decreases the font size of the selected text. 

Bold 

Clicking this button formats the selected text bold. 

Italic  

Clicking this button formats the selected text italic. 

Underline  

Clicking this button formats the selected text with an underline. 

Double Underline 

Clicking this button formats the selected text with a double underline. 

Word Underline  

Clicking this button formats the words in the selected text with an underline (omitting blank space 

between words). 

Strike out  

Clicking this button formats the selected text with a strike-out style. 

Left-aligned  

Clicking this button formats the selected paragraph left-aligned. 

Right-aligned  

Clicking this button formats the selected paragraph right-aligned. 

Centered 

Clicking this button formats the selected paragraph centered. 

Justified 

Clicking this button formats the selected paragraph justified. 

Bullets 

Clicking this button formats the selected text as a bulleted list. 

Numbered Lists 

Clicking this button formats the selected text as a numbered list. 

Increase Indentation  

Clicking this button increases the indentation of the paragraph in which the blinking text cursor is. 
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Decrease Indentation 

Clicking this button decreases the indentation of the paragraph in which the blinking text cursor is. 

Change Text Color 

Clicking this button changes the color of the selected text to the color shown on the button. If you 

click the little arrow on the button a color palette is displayed from which you can choose a different 

color. 

Highlight Text  

Clicking this button highlights the selected text with the color shown on the button. If you click the 

little arrow on the button a color palette is displayed from which you can choose a different color. 

Change Line Spacing 

If you click this button you can select from a list of line spacing values that will be applied to the 

selected paragraphs. 

Show/Hide Special Characters 

If you click this button special characters that are normally hidden (like the end-of-paragraph 

characters) will be displayed. 

Undo 

Clicking this button will undo the last editing action. Clicking the button repeatedly will undo 

previous editing actions one by one. 

Redo 

This button becomes active once you have clicked the Undo button and enables you to undo your 

Undo actions one by one. 

Insert Date  

Clicking this button inserts the current date. 

Insert Time  

Clicking this button inserts the time of day. 

Spell Check 

Use this button to turn As-You-Type spell-checking on or off. You can also open the Spelling Dialog by 

clicking this button and selecting Spell Check Dialog…: 
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Work Area 
The Work Area is where you enter and format text. It is framed by a horizontal and a vertical ruler (If 

set to be displayed on the View menu). 
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Horizontal and Vertical Ruler 

The rulers shown below are displayed in Page Layout view. If the word processor is in Draft view the 

page margin indicators will not be displayed. 
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